用hadoop-eclipse-plugins-2.6.0来配置hadoop-3.3.6

hadoop-eclipse-plugins这个插件是Eclipse中Hadoop的插件,但在寻找这个插件的过程中,突然发现插件的版本最好与hadoop的版本的一样

但我所能找到的最新版是3.3.1的,试了试,运行有问题,不能用

然后又试了试自己搭对应版本的hadoop-eclipse-plugins-3.3.6,一堆报错

又发现了一个博主说hadoop-eclipse-plugins-2.6.0的可以用

http://t.csdn.cn/VUoNFicon-default.png?t=N7T8http://t.csdn.cn/VUoNF

需要下载Eclipse之后,先不要打开Eclipse,将hadoop-eclipse-plugins-2.6.0的插件放到plugins目录下,再打开Eclipse即可

 若是报错错误: 找不到或无法加载主类 org.apache.hadoop.mapreduce.v2.app.MRAppMaster

可查看这个

http://t.csdn.cn/LSbkeicon-default.png?t=N7T8http://t.csdn.cn/LSbke 

 自己编译对应版本的hadoop-eclipse-plugins-插件,可查看http://t.csdn.cn/rYi7Nicon-default.png?t=N7T8http://t.csdn.cn/rYi7N

 文章来源地址https://www.uudwc.com/A/La06z/

原文地址:https://blog.csdn.net/m0_68319844/article/details/132814261

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处: 如若内容造成侵权/违法违规/事实不符,请联系站长进行投诉反馈,一经查实,立即删除!

上一篇 2023年09月15日 00:02
【Java|golang】210. 课程表 II---拓扑排序
下一篇 2023年09月15日 00:03